IT星球论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

新浪微博账号登陆

只需一步,快速开始

搜索
查看: 20|回复: 0

composer配置问题(终于解决啦)

[复制链接]

1996

主题

1

好友

1万

积分

管理员

Rank: 9Rank: 9Rank: 9

优秀会员 助人为乐 辛勤工作 技术精英 多才多艺 优秀班竹 灌水天才 星球管理 宣传大使 灌水之王 财富勋章 版主勋章 动漫勋章 勤奋会员 论坛精英 PS高手 心 8 闪游皮肤 双鱼座 8★8➹ 志愿者 乖

发表于 2017-7-7 16:34:23 |显示全部楼层
composer配置问题(终于解决啦)
  Composer 是 PHP5以上 的一个依赖管理工具。它允许你申明项目所依赖的代码库,它会在你的项目中为你安装他们。Composer 不是一个包管理器。是的,它涉及 "packages" 和 "libraries",但它在每个项目的基础上进行管理,在你项目的某个目录中(例如 vendor)进行安装。默认情况下它不会在全局安装任何东西。因此,这仅仅是一个依赖管理。
    安装好Composer时通过composer install,发现没有正常安装,而是提示:
  [Composer\Exception\NoSslException]
  The openssl extension is required for SSL/TLS protection but is not available. If you can not enable the openssl extension, you can disable this error , at your own risk, by setting the 'disable-tls' option to true.
   对于这个问题,我尝试使用下面的命令解决:
  1. composer config -g -- disable-tls true
复制代码
然而出现了另外的问题:
  [Composer\Downloader\TransportException]
  Your configuration does not allow connections to http://packagist.org/packages.json. See https://getcomposer.org/doc/06-config.md#secure-http for details.
    所以需要再次进行设置,禁用SSL
  1. composer config secure-http false
  2.     composer config -g secure-http false
复制代码
  之后,一部分可以正常安装了,还有一部分提示超过300stimeout,所以对时间进行设置:
    增加COMPOSER_PROCESS_TIMEOUT,通过命令composer config --list看到默认是300s,然后通过命令composer config -g process-timeout 600增加COMPOSER_PROCESS_TIMEOUT至600s。
    至此,Composer能够正常运行。
composer配置问题(终于解决啦)
该会员没有填写今日想说内容.
您需要登录后才可以回帖 登录 | 立即注册 新浪微博账号登陆

回顶部